Life Is Strange 2 Complete Season Available on Mac and Linux

December 19, 2019
Life Is Strange 2 Complete Season Available on Mac and Linux

Feral Interactive announced that all five episodes of Life is Strange 2, are out now on macOS and Linux.

Originally developed by DONTNOD Entertainment and published by Square Enix on PC and consoles, this is the much-anticipated sequel to 2015's BAFTA Award-winning Life is Strange.

After a tragic incident, brothers Sean and Daniel Diaz ran away from home. Fearing the police, and dealing with Daniel's newly manifested powers of telekinesis – the ability to move objects with his mind – the boys decide to travel to their father's hometown of Puerto Lobos in Mexico for safety.

Suddenly, sixteen year-old Sean is responsible for nine year-old Daniel’s safety, and teaching him right from wrong. As Daniel's power grows, it’s up to Sean to decide the rules by which they live.

System requirements for macOS:

Life is Strange 2 requires macOS 10.15, and is supported on the following Macs:

• All 13" MacBook Pros released since 2016
• All 15" MacBook Pros released since Late 2013 with a 2.3GHz i5 processor or better
• Mid-2015 models with an AMD R9 M370X graphics card are not supported
• All 13" MacBook Airs released since 2018
• All Mac minis released since 2018
• All 21.5" iMacs released since 2017
• All 27" iMacs released since Late 2014
• Late 2013 models with a 2GB Nvidia GeForce GTX 775M or 4GB Nvidia GeForce GTX 780M graphics card are also supported
• Late 2012 models with a 2GB Nvidia GeForce GTX 680M graphics card are also supported
• All 27" iMac Pros released since Late 2017
• All Mac Pros released since Late 2013

Linux system requirements:

Life is Strange 2 requires a 64-bit processor and operating system\u2028.

• OS: Ubuntu 18.04 64-bit\u2028
• Processor: 3.4GHz Intel Core i3-4130\u2028
• Memory: 4 GB RAM\u2028
• Graphics: NVIDIA GeForce GTX 680 2GB\u2028or AMD Radeon R9 380 4GB
• Storage: 42 GB available space\u2028

Additional Notes:

• Requires Vulkan
• NVIDIA requires 430.14 or newer drivers.
• AMD requires Mesa 19.1.2 or newer.
• Intel GPUs are not supported.